3 Apr 2008

We’re Compatible with WordPress 2.5!

I’m pleased to announce that our amazing comment platform Intense Debate is now compatible with WordPress 2.5.  That’s right!  Install it on your blog today and give your readers the tools to have a real conversation about your blog.

Not convinced?  Have a look at what people are saying about us!

Posted by Michael Koenig in WordPress Plugin


Missing out on the latest IntenseDebate developments? Enter your email below to receive future announcements direct to your inbox. An email confirmation will be sent before your subscription is activated - please check your spam folder if you don't receive this.

Join 4,688 other followers

0 Comments »

No comments yet.

RSS feed for comments on this post. TrackBack URI

Leave a comment

This work is licensed under a Creative Commons Attribution-NonCommercial-ShareAlike 2.5 License. | IntenseDebate – Official Blog
%d bloggers like this: